VLAN及VLAN间路由

发布于:2021-06-18 23:17:01

VLAN及VLAN间路由
vlan技术

虚拟局域网,逻辑的概念


一个网段,对应一个广播域,多个网段,代表多个广播域;


不同的网段需要通信,需要路由器;


如果有了VLAN技术,那么就可以在二层隔离广播,相同的VLAN可以互通,而不同VLAN的必须要经过三层设备才可以通信,提升了网络性能,并提高了网络的安全性。


VLAN是交换机支持的技术,为了让VLAN流量跨越交换机通信,出现了VLAN标签技术。


实际上,数据帧在交换机内部都是带标签的帧


交换机的接口:


接入端口(access端口):只允许一个VLAN数据通过(PVID的VLAN数据)trunk端口:可以允许多个VLAN数据通过,华为的设备默认只让PVID的过,需要配置允许的VLAN。trunk端口中传出的数据中,PVID的是不带标签的。

一般来说,交换机之间的应该配置成trunk,连接主机和终端的配成access。


交换机有一张VLAN映射表:vlan和交换机端口的对应关系。


交换机的标签技术:dot1.q:


在数据帧的源MAC地址和类型中间插入4个字节其中12个bit位用来表示VLAN-ID,所以最多4094个VLAN
VLAN的配置:
    创建VLAN

[sw1]vlan 10 #创建一个VLAN
[sw1]vlan batch 2 to 9 #批量创建VLAN 2-9

    配置端口类型


    接口端口:把端口加入到相应的VLAN即可

    interface Ethernet0/0/1
    port link-type access #配置接口为access接口
    port default vlan 100 #配置接口的PVID为vlan 100

    trunk端口:配置允许通过的VLAN即可

    interface GigabitEthernet0/0/1
    port link-type trunk #配置接口为trunk接口
    port trunk allow-pass vlan 2 to 4094 #配置允许通过的vlan列表


VLAN间路由技术

单臂路由技术:用的少

三层交换技术


三层交换机上的接口都是交换接口,不能直接配IP地址通过在三层交换机上创建vlanif接口实现的
VLAN必须存在VLAN中有活跃的接口vlanif接口实际上就是对应VLAN的网关 三层交换机其实就是一个路由器,可以配置路由

配置vlanif接口:

[l3-switch]vlan batch 2 to 9 #创建vlan

[l3-switch]interface GigabitEthernet 0/0/1 #配置物理接口为trunk
[l3-switch-GigabitEthernet0/0/1]port link-type trunk
[l3-switch-GigabitEthernet0/0/1]port trunk allow-pass vlan 2 to 9


[l3-switch]interface Vlanif 2 #配置vlanif接口,并将IP地址设为vlan2的网关地址
[l3-switch-Vlanif2]ip address 192.168.2.254 24

[l3-switch]interface Vlanif 3
[l3-switch-Vlanif3]ip address 192.168.3.254 24

配置路由


[l3-switch]vlan 254 #为了和路由器通信
[l3-switch-vlan254]description for-device-connect #增加描述信息

[l3-switch]interface GigabitEthernet 0/0/3 #将和路由器相连端口加入到VLAN254
[l3-switch-GigabitEthernet0/0/3]port default vlan 254

[l3-switch]interface Vlanif 254 #配置和路由器相连接口通信的IP地址
[l3-switch-Vlanif254]ip address 192.168.254.2 24

[l3-switch]ip route-static 0.0.0.0 0 192.168.254.1 #配置默认路由,下一跳指向路由器接口IP地址

相关推荐

最新更新

猜你喜欢